Support for old software versions will once cease. That is not different for Joomla. Recent outdated versions can be updated without too many problems to newer versions.

Very outdated versions might require a migration path.

Joomla 2.5

To switch from Joomla 2.5 to Joomla 3.x requires an update. Joomla 1.6 and 1.7 can be updated via Joomla 5.2.28 to Joomla 3.x. Sometimes there are small adjustments necessary, particularly legacy extensions and template adjustments. Joomla 5.2.28 is the latest version in the Joomla 2.5 series. This version is no longer supported since December 31, 2014 with (security) patches.

Joomla 1.5

The program code and database structure of Joomla 1.5 is so different that you can only to update to Joomla 3 via a migration. Older versions of Joomla usually keep working for a long time, provided that the party hosting the server software (PHP) do not upgrade to newer versions. For safety reasons it is advisable to keep all software up to date. Joomla 1.5.26 is the latest version and is no longer supported with (security) patches since September 2012.

Joomla 1.0

Joomla 1.0 was released in 2005. Joomla 1.0.15 is the latest version, and is no longer officially supported by Joomla since July 22, 2009.

Extensions

Besides the Joomla software extensions are often used in Joomla websites. Such a 3rd party extensions are sometimes difficult to migrate. Or they are not available for new Joomla versions. db8 can assist in the migration to newer versions of Joomla.